Skip to main content
← All vulnerabilities
CVE-2026-15810

Cross-Site Scripting (XSS) in Looker allows Admin Account Takeover

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, and 3 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

A Cross-Site Scripting (XSS) vulnerability in Google Cloud Looker versions prior to 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, and 26.8.7 on Looker-hosted and Self-hosted allows an attacker to execute arbitrary JavaScript leading to administrative account takeover using a maliciously crafted URL. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded to the patched versions: 25.6.103+, 25.12.65+, 25.18.68+, 26.0.66+, 26.2.47+, 26.4.36+, 26.6.28+, or 26.8.7+.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Google Cloud Looker

    fixed in 25.6.103; fixed in 25.12.65; fixed in 25.18.68; fixed in 26.0.66; fixed in 26.2.47; fixed in 26.4.36; fixed in 26.6.28; fixed in 26.8.7

  • Google Cloud Looker

    fixed in 25.6.103; fixed in 25.12.65; fixed in 25.18.68; fixed in 26.0.66; fixed in 26.2.47; fixed in 26.4.36; fixed in 26.6.28; fixed in 26.8.7

References 2

docs.cloud.google.com