Skip to main content
← All vulnerabilities
CVE-2026-15529PYSEC-2026-3909GHSA-997V-R4V7-9F3G

yzhao062 pyod persistence.py pyod.utils.persistence.load deserialization

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.6.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

A vulnerability was detected in yzhao062 pyod up to 3.6.1. Affected is the function pyod.utils.persistence.load of the file pyod/utils/persistence.py. Performing a manipulation of the argument path results in deserialization. The attack can be initiated remotely. Upgrading to version 3.6.2 is able to address this issue. It is recommended to apply a patch to fix this issue. The pull request to fix this issue requires some minor changes.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • yzhao062 pyod

    3.5.0, 3.5.1, 3.5.2, 3.5.4, 3.6.0, 3.6.1

  • pyodPyPI

    From 3.5.0 · fixed in 3.6.2

References 8

VulDB

GitHub · yzhao062/pyod

pypi.org