Skip to main content
← All vulnerabilities
CVE-2026-14664

PostgreSQL regexp heap buffer overflow executes arbitrary code

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 18.6, 17.11, 16.15, 15.19, 14.24
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Heap buffer overflow in PostgreSQL regexp allows the query author to execute arbitrary code as the operating system user running the database, via text that would not pass encoding validation. This shares heritage with CVE-2026-2006, but this case involved unanticipated data growth when round-tripped through pg_wchar. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected.

Timeline

  1. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  2. CVE published
  3. Record last updated

Affected versions

  • n/a PostgreSQL

    From 18 · fixed in 18.6; From 17 · fixed in 17.11; From 16 · fixed in 16.15; From 15 · fixed in 15.19; fixed in 14.24

References 1

postgresql.org