Skip to main content
← All vulnerabilities
CVE-2026-12773GHSA-4JCJ-7X88-M979PYSEC-2026-4067

BerriAI litellm MCP Proxy user_api_key_auth_mcp.py UserAPIKeyAuth improper authentication

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.84.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: yes
  • Technical impact: partial

Summary

A weakness has been identified in BerriAI litellm up to 1.59.8. Affected is the function UserAPIKeyAuth of the file litellm/proxy/_experimental/mcp_server/auth/user_api_key_auth_mcp.py of the component MCP Proxy. Executing a manipulation can lead to improper authentication. The attack may be launched remotely. The exploit has been made available to the public and could be used for attacks. The vendor was contacted early about this disclosure.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • BerriAI litellm

    1.59.0, 1.59.1, 1.59.2, 1.59.3, 1.59.4, 1.59.5, 1.59.6, 1.59.7, 1.59.8

  • litellmPyPI

    fixed in 1.84.0

References 5

VulDB

gist.github.com